Welcome to the Australian Ford Forums forum.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and inserts advertising. By joining our free community you will have access to post topics, communicate privately with other members, respond to polls, upload content and access many other special features without post based advertising banners. Registration is simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact us.

Please Note: All new registrations go through a manual approval queue to keep spammers out. This is checked twice each day so there will be a delay before your registration is activated.

Go Back   Australian Ford Forums > Ford Australia Vehicles > Small and Mid Sized Cars > Laser and Telstar

Reply
 
Thread Tools Display Modes
Old 23-10-2016, 08:38 PM   #1
DrFalconstein
Starter Motor
 
Join Date: Aug 2007
Posts: 12
Default 1999 Laser engine stalls

Hi wonder if anyone has had this problem, Ive got a 1999 Laser 1.6 5 speed manual.
When sitting in traffic for a long period of time, or crawling in traffic the engine revs drop and the engine will stop running. and wont re start for about 5 min.
ive replaced the Air flow meter. Its like its not getting enough fresh air, the cars drives great when on the open road.
Cheers Darren
DrFalconstein is offline   Reply With Quote Multi-Quote with this Post
Old 23-10-2016, 09:13 PM   #2
GTLEGEND
FF.Com.Au Hardcore
 
Join Date: Mar 2013
Posts: 3,745
Technical Contributor: For members who share their technical expertise. - Issue reason: The quality of information he provides is in depth and highly valued by those posting questions. Valued Contributor: For members whose non technical contributions are worthy of recognition. - Issue reason: Every advice post I visit where OP are seeking advice for their new vehicle, he is there and adds valuable support and advice for rectifying the problem. Really is a Legend. 
Default Re: 1999 Laser engine stalls

Sounds like a sensor is playing up with heat...cam or crank angle sensor or coil pack would be my guess for cause of no spark. You need to check for lack of spark or fuel when the vehicle does not start...
GTLEGEND is offline   Reply With Quote Multi-Quote with this Post
Old 13-02-2017, 09:57 PM   #3
DrFalconstein
Starter Motor
 
Join Date: Aug 2007
Posts: 12
Default Re: 1999 Laser engine stalls

Ive just changed the crank angle sensor, car drives great for 30min then starts to splutter under acceleration ! engine running but when you accelerate it has no power then cuts out. starts up after 5 to 10 min
can hear the fuel pump working
I want to solve this problem without it costing, need to sell the car
Thanks
DrFalconstein is offline   Reply With Quote Multi-Quote with this Post
Old 14-02-2017, 12:14 AM   #4
GTLEGEND
FF.Com.Au Hardcore
 
Join Date: Mar 2013
Posts: 3,745
Technical Contributor: For members who share their technical expertise. - Issue reason: The quality of information he provides is in depth and highly valued by those posting questions. Valued Contributor: For members whose non technical contributions are worthy of recognition. - Issue reason: Every advice post I visit where OP are seeking advice for their new vehicle, he is there and adds valuable support and advice for rectifying the problem. Really is a Legend. 
Default Re: 1999 Laser engine stalls

Quote:
Originally Posted by DrFalconstein View Post
Ive just changed the crank angle sensor, car drives great for 30min then starts to splutter under acceleration ! engine running but when you accelerate it has no power then cuts out. starts up after 5 to 10 min
can hear the fuel pump working
I want to solve this problem without it costing, need to sell the car
Thanks
Just because you can hear the fuel pump working, does not mean it is working correctly and sending the right amount of pressure and volume, especially when more fuel is required such under acceleration and increased loads. I would firstly take off the fuel supply line at the rail and measure the amount of fuel in volume over a certain period of time (would need to look the spec up) and then put a pressure gauge and see what the pressure is when driving and the problem occurs. Blocked fuel filter could also be a cause.

Check these as a first step..
GTLEGEND is offline   Reply With Quote Multi-Quote with this Post
Old 21-02-2017, 05:11 PM   #5
DrFalconstein
Starter Motor
 
Join Date: Aug 2007
Posts: 12
Default Re: 1999 Laser engine stalls

ok thanks, it stops mostly when waiting at lights after 30 min of driving.
last drive when it faltered the engine was running whilst rolling but would splutter when accelerating then cuts out altogether
DrFalconstein is offline   Reply With Quote Multi-Quote with this Post
Old 21-02-2017, 08:30 PM   #6
GTLEGEND
FF.Com.Au Hardcore
 
Join Date: Mar 2013
Posts: 3,745
Technical Contributor: For members who share their technical expertise. - Issue reason: The quality of information he provides is in depth and highly valued by those posting questions. Valued Contributor: For members whose non technical contributions are worthy of recognition. - Issue reason: Every advice post I visit where OP are seeking advice for their new vehicle, he is there and adds valuable support and advice for rectifying the problem. Really is a Legend. 
Default Re: 1999 Laser engine stalls

Also check if there is spark when the concern occurs, could also be the dizzy module, or other parts of the dizzy.
GTLEGEND is offline   Reply With Quote Multi-Quote with this Post
Old 22-02-2017, 07:32 PM   #7
DrFalconstein
Starter Motor
 
Join Date: Aug 2007
Posts: 12
Default Re: 1999 Laser engine stalls

is the fuel filter under the car near the tank ?
DrFalconstein is offline   Reply With Quote Multi-Quote with this Post
Old 23-02-2017, 04:53 PM   #8
GTLEGEND
FF.Com.Au Hardcore
 
Join Date: Mar 2013
Posts: 3,745
Technical Contributor: For members who share their technical expertise. - Issue reason: The quality of information he provides is in depth and highly valued by those posting questions. Valued Contributor: For members whose non technical contributions are worthy of recognition. - Issue reason: Every advice post I visit where OP are seeking advice for their new vehicle, he is there and adds valuable support and advice for rectifying the problem. Really is a Legend. 
Default Re: 1999 Laser engine stalls

Carby has a plastic one on the firewall on the passenger side under the charcoal canister.

EFI engines have a metal one basically in the same spot...
GTLEGEND is offline   Reply With Quote Multi-Quote with this Post
This user likes this post:
Reply

Thread Tools
Display Modes

Forum Jump


All times are GMT +11. The time now is 05:10 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Other than what is legally copyrighted by the respective owners, this site is copyright www.fordforums.com.au
Positive SSL