Welcome to the Australian Ford Forums forum.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and inserts advertising. By joining our free community you will have access to post topics, communicate privately with other members, respond to polls, upload content and access many other special features without post based advertising banners. Registration is simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact us.

Please Note: All new registrations go through a manual approval queue to keep spammers out. This is checked twice each day so there will be a delay before your registration is activated.

Go Back   Australian Ford Forums > Ford Australia Vehicles > Small and Mid Sized Cars > Laser and Telstar

Reply
 
Thread Tools Display Modes
Old 09-10-2011, 08:54 PM   #1
samcharles93
Starter Motor
 
Join Date: Sep 2011
Posts: 1
Default Telstar TX5 Ghia AV

need help. engine overheating smoke coming from overhead cam, main engine block. in park/neutral revving between 1 1/2, 2 up and down. though maybe thermostat gone. Any thoughts? cheers.
samcharles93 is offline   Reply With Quote Multi-Quote with this Post
Old 09-10-2011, 09:32 PM   #2
toothless
FF.Com.Au Hardcore
 
toothless's Avatar
 
Join Date: Jan 2011
Location: Kingswood
Posts: 1,937
Default Re: Telstar TX5 Ghia AV

coolant needs to be bleed properly
__________________
phat ltd in the making very lowly
toothless is offline   Reply With Quote Multi-Quote with this Post
Reply

Thread Tools
Display Modes

Forum Jump


All times are GMT +11. The time now is 02:44 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Other than what is legally copyrighted by the respective owners, this site is copyright www.fordforums.com.au
Positive SSL